Ticket #221 (closed enhancement: fixed)

Opened 9 years ago

Last modified 9 years ago

hyp2000_mgr concatenates the hypo.prt file with each record, can it be a new file instead

Reported by: paulf Owned by: somebody
Priority: major Milestone: All Platforms
Component: hyp2000_mgr Version: 7.6
Keywords: Cc:

Description

Victor H. at PRSN requests:

Is there any way to split the hypo out file to record single event files? i mean, in the *.hyp file the PRT command define the *.prt file with the locations (auto locations), the problem is that file becomes a monster as it save all the locations. Our system detects more than 500 in few days and that file grows out of control. 

This should be an option in hyp2000_mgr so we don't break any existing installations. I would expect that a time-stamp+qid named .prt file would be best

Change History

comment:1 Changed 9 years ago by paulf

  • Status changed from new to closed
  • Resolution set to fixed

Today I created a new version of hyp2000_mgr (version 1.39), checked into svn as r5052, that supports a new option:

SeparatePRTdir dirname

Which will write out PRT files per event in this directory (which must already exist). Note this overrides anything in the hypoinverse command file being passed in on the hyp2000_mgr command line.

The len of the dirname should be less than 50 chars since this gets padded with the filename which is of the format: YYYYMMDDHHmmSS.QID.prt where time is the origin time from binder_ew and QID is the quake id padded with zeros.

From my run on the memphis test I see this:

pauls-MacBook-Air:params paulf$ ls prt
20060907135113.0000000309.prt
pauls-MacBook-Air:params paulf$ 
Note: See TracTickets for help on using tickets.