Ticket #671 (closed defect: fixed)

Opened 5 months ago

Last modified 5 months ago

ubuntu 18.04 EW 7.9 compile error for sudsputaway.c

Reported by: paulf Owned by: somebody
Priority: major Milestone:
Component: ALL modules Version:
Keywords: Cc:

Description

A user sent us this directly:

From: Ran Nof <rann@…> Subject: Earthworm compiling error

Message Body: Trying to compile earthworm 7.9 on UBUNTU 18.04 gives following error:

Note! environments are set with: sed -i 's/export EWBITS=32/export EWBITS=64/' environment/ew_linux.bash

systems is installed with packages: make autoconf automake libtool gcc gfortran g++ gcc-multilib ######### ERROR MESSAGE: ######### sudsputaway.c: In function 'SUDSPA_next': sudsputaway.c:451:32: error: 'INT32_MIN' undeclared (first use in this function); did you mean 'INT_MIN'?

if (l_data[j] < (float)INT32_MIN)

INT_MIN

sudsputaway.c:451:32: note: each undeclared identifier is reported only once for each function it appears in sudsputaway.c:453:38: error: 'INT32_MAX' undeclared (first use in this function); did you mean 'INT32_MIN'?

else if (l_data[j] > (float) INT32_MAX)

INT32_MIN

Change History

comment:1 Changed 5 months ago by paulf

  • Status changed from new to closed
  • Resolution set to fixed

Ran Nof downloaded latest from SVN and tested there and all compiled cleanly on this version of Ubuntu. Closing the ticket.

Note: See TracTickets for help on using tickets.